Login geht, aber sonst nichts

Eine Sammlung von PHP-Funktionen zum Auslesen von ChatDaten.
gulliver4712
Beiträge: 7
Registriert: 12.11.2015, 21:57

Login geht, aber sonst nichts

Ungelesener Beitrag von gulliver4712 » 14.07.2018, 23:14

Ich versuche folgendes Script zu nutzen (original aus der API Dokumentation):

Code: Alles auswählen

<?php
if (version_compare(PHP_VERSION, '5.3.0') >= 0){
  require("api_v2.php");
  try {
    $chat = new wkAPI(3, "wkchat", "username", "Super-Geheimes-Passwort");
    $chat->login();
    sleep(1);
    $chat->sendeText("Ich bin eingeloggt!");
    sleep(1);
    $chat->logout();
  } catch (Exception $e){
    print $e->getMessage();
  }
} else {
  echo "Deine PHP-Version ist zu alt!";
}
?>
Der Benutzer loggt sich astrein ein (also scheint die API zu funktionieren) - aber der Benutzer sendet keinen Text in den Chat und kann sich daher folglich auch nicht wieder ausloggen.

Wo liegt mein Fehler? Der Benutzer "username" ist ein stinknormaler Benutzer (Level Chatter).

gulliver4712
Beiträge: 7
Registriert: 12.11.2015, 21:57

Re: Login geht, aber sonst nichts

Ungelesener Beitrag von gulliver4712 » 20.07.2018, 15:29

Kann mir denn wirklich niemand helfen bei diesem Thema?

Benutzeravatar
Linus
Moderator
Beiträge: 1053
Registriert: 14.02.2005, 20:31
Wohnort: NRW
Kontaktdaten:

Re: Login geht, aber sonst nichts

Ungelesener Beitrag von Linus » 17.08.2018, 22:37

Die API hatte dort offenbar einen Fehler. Wenn du die api_v2.php neu von GitHub lädst sollte es funktionieren ;)
Kein Support per PN!

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast